OpenRoads Designer CONNECT Edition SDK Help

CreateTangentParabolaTwoElementsByRadius Method

Constructs a profile parabola element tangent to two profile elements.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileParabola[]CreateTangentParabolaTwoElementsByRadius( ProfileElement elmt1, ProfileElement elmt2,double radius)

Parameters

SettingDescription
  ProfileElement The first profile element which the created profile line is tangent to.
  ProfileElement The second profile element which the created profile line is tangent to.
   The through passing point of the parabola

Return Value

ProfileParabola[] The tangent profile parabola elements cli::array

See Also